Debian: Heal Selection für Gimp

Alle möglichen Probleme mit Software
Beiträge: 65
Registriert: Fr 6. Aug 2021, 21:06
Has thanked: 7 times
Been thanked: 18 times

Debian: Heal Selection für Gimp

Beitrag von Alexs »

Hallo,

ich habe in früher in Gimp oft das Plugin Resynthesizer (Heal Selection) verwendet um kleine Bildausschnitte schnell zu retuschieren, der Vorteil gegenüber die mühevolle Handarbeit war, dass man lediglich mit dem Lasso den gewünschten Bereich markieren musste und Heal Selection machte dass dann von selbst.

Leider war Heal Selection vom Paket gimp-python abhängig, welches – warum auch immer – von Gimp nicht mehr gepflegt wird, somit kann Gimp keine Python-Scripte wie nicht mehr ausführen.
Eine der alten Bug-Meldungen: https://bugs.debian.org/cgi-bin/bugrepo ... bug=907178

Wen wer hier vielleicht ein Python-Programmierer ist – die Hoffnung stirbt bekanntlich zuletzt –, könnte sich das jemand ansehen, ob man das Plugin nicht irgendwie auf die aktuelle Gimp-Version aktualisieren (oder auf Perl oder Tcl portieren) kann?
gimp-python gibt es nur noch in buster:
https://packages.debian.org/de/buster/gimp-python
Das letzte Paket wo Heal Selection noch enthalten ist, befindet sich ebenfalls nur noch im buster-Zweig.
https://packages.debian.org/de/buster/g ... n-registry
Im Quelltext scheint das Plugin (von 2018!) auch noch vorhanden zu sein.
http://deb.debian.org/debian/pool/main/ ... 625.tar.gz

Benötigt wird für die Ausübung der Funktion folgende Dateien:
  • resynthesizer
  • resynthesizer_gui
  • plugin-heal-selection.py
  • plugin-heal-transparency.py (alternativ)
Da ich die anderen Sachen nie benötigte, habe ich die drei Dateien immer in ~/.config/GIMP/2.10/plug-ins/ kopiert.

Hier noch ein Beispiel-Video wie Heal Selection bei mir früher funktioniert(e):


Oder weiß jemand wie ich das Plugin unter der aktuellen Gimp-Version zum laufen bekomme?
Bild
Beiträge: 17
Registriert: Mo 9. Aug 2021, 20:14
Has thanked: 18 times
Been thanked: 2 times

Re: Debian: Heal Selection für Gimp

Beitrag von neloCR »

Das Problem momentan ist, dass GIMP 2.10 noch mit Python2 arbeitet ... das ist inzwischen mausetot und aus den meisten Distris längst raus. GIMP 3 wird, so es denn mal kommt, mit Python 3 arbeiten, aber das dauert wohl noch ( da ist halt auch geringe manpower hinter)
Die Standardinstallation von GIMP wäre ein flatpak. Und dafür wäre resynthesizer verfügbar. Das flatpak bringt sein Python 2 einfach mit. Wenn du flatpak installiert hast, kannst du die verfügbaren Teile so abfragen:

Code: Alles auswählen

flatpak search GIMP:

Code: Alles auswählen

GNU Image Manipul… Bilder erstellen und Fotografien bearbeiten                                       org.gimp.GIMP              2.10.30 stable flathub
GIMP User Manual   GIMP User Manual                                                                  org.gimp.GIMP.Manual       2.10    2.10   flathub
Resynthesizer      Set of GIMP plug-ins that heal (in-paint), synthesize texture, theme an image, a… …GIMP.Plugin.Resynthesizer 2.0.3   2-40   flathub
Resynthesizer      Set of GIMP plug-ins that heal (in-paint), synthesize texture, theme an image, a… …GIMP.Plugin.Resynthesizer 2.0.3   2-3.36 flathub
GimpLensfun        GimpLensfun is a Gimp plugin to correct lens distortion using the lensfun librar… ….gimp.GIMP.Plugin.Lensfun 0.2.4   2-40   flathub
GimpLensfun        GimpLensfun is a Gimp plugin to correct lens distortion using the lensfun librar… ….gimp.GIMP.Plugin.Lensfun 0.2.4   2-3.36 flathub
Fourier            A simple GIMP plug-in to do fourier transform on your image.                      ….gimp.GIMP.Plugin.Fourier 0.4.3   2-40   flathub
Fourier            A simple GIMP plug-in to do fourier transform on your image.                      ….gimp.GIMP.Plugin.Fourier 0.4.3   2-3.36 flathub
BIMP               Batch Image Manipulation Program, a GIMP plugin to apply a set of manipulations … org.gimp.GIMP.Plugin.BIMP  2.6     2-40   flathub
BIMP               Batch Image Manipulation Program, a GIMP plugin to apply a set of manipulations … org.gimp.GIMP.Plugin.BIMP  2.5     2-3.36 flathub
LiquidRescale      LiquidRescale plugin to resize pictures non uniformly while preserving their fea… …GIMP.Plugin.LiquidRescale 0.7.2   2-40   flathub
LiquidRescale      LiquidRescale plugin to resize pictures non uniformly while preserving their fea… …GIMP.Plugin.LiquidRescale 0.7.2   2-3.36 flathub
G'MIC              GREYC's Magic for Image Computing                                                 org.gimp.GIMP.Plugin.GMic  3.0.2   2-40   flathub
G'MIC              GREYC's Magic for Image Computing                                                 org.gimp.GIMP.Plugin.GMic  2.9.6   2-3.36 flathub
FocusBlur          Focus Blur plug-in crete a blurring effect similar to Depth of Field.             …imp.GIMP.Plugin.FocusBlur 3.2.6   2-40   flathub
FocusBlur          Focus Blur plug-in crete a blurring effect similar to Depth of Field.             …imp.GIMP.Plugin.FocusBlur 3.2.6   2-3.36 flathub
Glimpse            Bilder erstellen und Fotografien bearbeiten                                       org.glimpse_editor.Glimpse 0.2.0   stable flathub
Scans to PDF       Create small, searchable PDFs from scanned documents                              com.github.unrud.djpdf     0.1.6   stable flathub
Muss man halt überlegen, ob man solange, bis GIMP3 mal spruchreif ist, in den flatpak Apfel beißen möchte.
Beiträge: 65
Registriert: Fr 6. Aug 2021, 21:06
Has thanked: 7 times
Been thanked: 18 times

Re: Debian: Heal Selection für Gimp

Beitrag von Alexs »

neloCR hat geschrieben: So 6. Mär 2022, 20:40 Das Problem momentan ist, dass GIMP 2.10 noch mit Python2 arbeitet ... das ist inzwischen mausetot und aus den meisten Distris längst raus. GIMP 3 wird, so es denn mal kommt, mit Python 3 arbeiten, aber das dauert wohl noch ( da ist halt auch geringe manpower hinter)
Danke neloCR, dass hatte ich irgendwie befürchtet. dass Gimp hinterherhinkt.
neloCR hat geschrieben:Die Standardinstallation von GIMP wäre ein flatpak. Und dafür wäre resynthesizer verfügbar. Das flatpak bringt sein Python 2 einfach mit. Wenn du flatpak installiert hast, kannst du die verfügbaren Teile so abfragen:
(…)
Muss man halt überlegen, ob man solange, bis GIMP3 mal spruchreif ist, in den flatpak Apfel beißen möchte.
Ich bin früher bei der Problemsuche auch auf flatpak/Gimp gestoßen, aber für die paarmal wo ich das Python-Plugin wirklich brauche, lohnt sich das für mich nicht. Muss ich halt weiterhin manuell heilen und klonen. Schade.
Bild
Beiträge: 16
Registriert: So 24. Okt 2021, 15:38
Wohnort: Niedersachsen

Has thanked: 2 times

Re: Debian: Heal Selection für Gimp

Beitrag von markusbuech »

Hallo zusammen,

vielleicht hilft eine (nicht mehr ganz so aktuelle) AppImage-Version von Gimp. Unter https://github.com/aferrero2707/gimp-appimage/releases bei "Assets" gibt es eine Version "GIMP_AppImage-git-2.10.25-20210610-withplugins", da ist das im Plugin-Manager gelistet. Ob das reicht weiss ich nicht, da ich mit Gimp leider nicht so klar komme.


Viele Grüsse

Markus
Antworten Vorheriges ThemaNächstes Thema

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste